serverich hatte meine nas ja von banana pro auf raspberry pi 3 umgestellt. das war keine so gute idee ... warum? datenraten von meist unter 10 mbit waren die folge.
nachdem ich meiner holden nen neuen bürorechner auf intel nuc-basis ( Intel NUC-Kit i3 mit 128gb ssd und  8gb ram ) gegönnt habe, hatte ich ne idee ...

ich hab noch einen intel nuc gekauft, diesmal aber "nur" mit nem celeron drinnen. wieder mit 8 gb ram und ner ssd (vorsicht: keine m.2, sondern 2,5" muß da rein), die ich noch rumliegen hatte.
dann wollt ich wieder openmediavault installieren. hat nur nicht gefunzt. das ding schreit nach treibern, die dann nicht wirklich funzen. bei nem debian dasselbe, nur ubuntu würde problemlos out-of-the-box rennen. da dacht ich mir, dass ich auch gleich windoof nehmen könnte. irre genug bin ich ja *bg*. gut, ich hab ja noch ne win10home lizenz hier rumliegen gehabt,die ich sonst eh nie gebraucht hätte.
was soll ich sagen? funzt natürlich sofot und geht ab wie lumpi auf der flucht vor nem katzenrudel.


was rennt?

  • natürlich erst mal freigaben. eigentlich keine arbeit und nun natürlich auf den windoof-clients wesentlich simpler zu machen. sprich: mit dem richtigen user, haste auch gleich den richtigen zugriff ohne passwörter und rechtekonflikte. einzig nervig - win-konten gehen auf android nicht. für die muß ich immer noch lokale user anlegen - nervig, aber zu überleben.
  • ein dlna-system gehört natürlich drauf. win bringt da ja schon eines mit (Systemsteuerung\Alle Systemsteuerungselemente\Netzwerk- und Freigabecenter\Medienstreamingoptionen), aber ich probier derzeit mal den serviio mezzmo (der versorgt meine lg-tivi's wesentlich besser) aus, weil mein lg-tv mit manchen formaten nicht wirklich will, und serviio mezzmo das on-the-fly umrechnet. geht super, nur meine flac's muß ich noch zum spielen bekommen.
  • mein geliebter jdownloader muß natürlich auch mit dabei sein. der startet auch automatisch per aufgabenplanung schon vor der useranmeldung.

probleme?

  • probleme hat die nuc vor allem beim rückspielen meiner backups gemacht. 2 usb3-platten (davon eine mit ext4-system und entsprechenden tools zum einbinden) + wlan + lan + tastatur und maus und ein serviio mezzmo beim abgrasen der neuen files, haben das arme stück an seine grenzen gebracht. das resultierte gern in wlan-ausfällen. headless und mit nur 1 ext. hdd rennt das ding aber problemlos und rund.
  • trotz neuester treiber zuckt das ding am hdmi-port immer wieder gerne. am neueren nuc fürs büro stehts wie ne 1. scheint also eher ein problem von nicht ganz neuen nuc's zu sein. who cares? ich will ja ne nas, kein mediacenter *g*.
  • ich selbst *g* ... der celeron flutscht super. bei normalen aktivitäten flutscht alles, wie von starken rechnern gewohnt. hat man dann aber gröberes vor - z.b den mezzo für alle videos untertitel umrechnen zu lassen - geht er schon sehr in die knie. an das mußt ich mich erst gewöhnen und mal abwarten, bevor man den taskmanager alles killen lasst, weil man glaubt irgendwas hängt ... ooommmmmm ...

was hab ich bis jetzt so an unterschieden zu meiner alten nas entdeckt?

die stromsparfunktionen vor allem:

omv hats ja nie wirklich geschafft, meine icy-box (dient immer noch als datengrab *g*) in den sleep zu kriegen. das macht win ohne jede einstellung automatisch. keine aktivität bedeutet 15 sek. später eine pennende platte. greift gar nix auf die nas zu, fahrt sie in den ruhezustand - ausser der jd ist noch am saugen. ich muß mich um nix kümmern, ausser ums aufwecken.
aufwecken tu ich das ding mit meiner hausautomatisation. ich überwach die nas per winconnect-modul , fahre sie damit runter und wecke die nas mit dem wol-modul auf, wann immer ich lustig bin. automatisch aufgeweckt wird, wenn z.b. ein dlna-fähiger tv am tag eingeschaltet wird, mein ratomat anstartet, oder einer der pc's los legt. nur für die androiden ist mir noch nix eingefallen, da muß ich per hausautomatisation das einschaltknopferl (aktiviert das wol-modul) drücken, wenn die nas pennt.

die übertragungsgeschwindigkeiten:

raspi-user waren mir ja schon die 50 mb/s auf meinem banana pro neidig. jetzt weiß ich auch warum. der raspi schafft mit viel bauchweh 20 mb/s, gern aber auch unter 10 mb/s. jetzt übertrag ich im netz mit 100 bis 120 mb/s.

die wartung:

eine grafische fernwartung für win ist halt schon mal um ecken besser als die kombination aus weboberfläche, winscp und kiddy um alle aspekte der alten nas abzudecken. ärgerlich hier nur: der windowseigene remotedesktop (server) is unter win10home nicht vorhanden. derzeit behelf ich mir mit teamviewer, such aber verzweifelt nach ner kostenlosen lösung ohne cloudanbindung.